very nice rewrite
Perhaps another useful way to explain this important feature is to contrast that
- a non-inverse predicate returns pages that have the named page-property, that is, subjects of a triple
- an inverse predicate returns pages referenced by the named page-property, that is, objects of a triple
Please note, I used the term "inverse predicate" not "inverse property" because there may be confusion with owl:inverseProperty relations, that is, it's more technically correct to reference the operation of resolving predicates than it is to reference a property per se. This general comment might affect for instance how the first sentence is worded from "The inverse of a property simply is the property that points into the other direction." to
- A query, composed of predicates, normally returns pages having a certain property. An 'inverse predicate' is simply an expression that returns pages referenced by a certain property. This feature (indicated by a hyphen in a predicate expression) only applies to queries, not to annotations for a page.
- For example, ...
I know it may be a pain, but if you agree that 'inverse predicates' is better, then I'd suggest the page title should be changed in accordance with this terminology.
Second, it'd be great to provide an example of what is meant by "It is strongly suggested not to create property pages that are called like inverse properties (it won't destroy anything, but it might create unnecessary confusion)."
Finally the last sentence is a bit confusing: I don't see how an inverse predicate works for text values. So, instead of "currently only supported if they are of Type:Page" how about "is only supported for page properties" ?
Heiya John, I agree that this page should be worked on. It should be easier to grasp what it is all about. I am however not so sure about renaming this to predicate though I understand your point, at least I think I do. :) Cheers
I think a more appropriate title would be "Help:Inverse queries" and the page should be listed in the menu under "Inline queries" (rather than "Properties", as it is now).
agreed - who/how should this kind of change be made?