How to migrate to SMWSQLStore3 without shell access?


I guess the tables were not created. What happened when doing step 4 via Special:SMW-Admin?

17:54, 8 February 2013

I couldn't even get to step 4.

I transfered the new files (SMW 1.8) to my server and called the directory "SemanticMediaWiki_new". If I don't have the line $smwgDefaultStore = 'SMWSQLStore2'; and I rename the directory to "SemanticMediaWiki" (so that it becomes active) I immediately get the error message.

If I have the line $smwgDefaultStore = 'SMWSQLStore2'; it works and SMW 1.8 is shown in Special:Version (like it is now) - but as soon as I remove the line I get the error...

21:02, 8 February 2013

I am quite sure that you are not on Special:SMW-Admin when getting this error. What happens if you enter the URL to Special:SMW-Admin directly in the browser?

14:50, 9 February 2013

I'm pretty sure I tested this as well and received the same error message...

Is it maybe a problem if I have two directories with SMW in my extensions folder - one called "SemanticMediaWiki", the other one called "SemanticMediaWiki_old" ?

15:01, 9 February 2013

My fault - it seems I wasn't at Special:SMW-Admin when I received the errors in February.

Now I managed to update my database to SMWSQLStore3 :)
I ran the database update twice (as you suggested). Just for curiosity: Why does it need to run two times?

21:03, 13 April 2013

Ouch, I did not notice you post of Feb. 9, 2013 or forgot to answer O_o. Cool that it worked out for you. It would have been really really weird if you were on Special:SMW-Admin and receiving this error. I think that Markus posted to the mailing list on why the refresh has to be done twice. I cannot remember what it was, but it is definitely necessary since to my experience only about two thirds of the job is done in the first run.

18:41, 30 April 2013

Thanks for your reply.
I guess it's time to implement the Like button into LQT :)

17:27, 1 May 2013