Discuss Semantic search

From semantic-mediawiki.org

Talk pages on this wiki should primarily be used to address possible mistakes as well as missing and superseded information in the documentation.
In case you are seeking support concerning individual questions, please have a look at this page. The Semantic MediaWiki user mailing list is always a good idea for seeking help.

archive of previous talk

Contents

Thread titleRepliesLast modified
Special:Ask216:04, 13 February 2021
SMW not tracking redirects117:39, 26 February 2013

Special:Ask

The article has a couple of references to Special:Ask, which apparently does not exist. Could some expert please fix it somehow?

11:41, 13 February 2021

Oops - now I see what the real problem is: the links are to Help:Special:Ask. I would fix it myself if I could see how to edit the article.

11:45, 13 February 2021

There is not easy/fast fix for this otherwise I would have done it already. The database of this wiki is more or less in a state of mess. Anyhow thanks for caring and reporting.

16:04, 13 February 2021
 
 

SMW not tracking redirects

I have a few pages that I recently renamed (updating all of the redirects), and ever since that time none of their redirects have been appearing in {{#ask}} queries based on their pagenames. For example, I have a page that I renamed from Infliximab to PF-06438179, and it has 26 redirects. Before, a template on the page with a query of the form

The part "..." of the query was not understood.</br>Results might not be as expected.

listed 53 pages, but ever since the move it only lists the 6 that direct-link to the page (ignoring the 47 that link to redirects).

  • I've performed dummy-edits on all of the redirects multiple times to try to refresh the index
  • I've performed dummy-edits on the page and the template to try to refresh the {{#ask}} function
  • I've performed dummy-edits on a few of the pages linking to redirects to try to refresh the semantic tags
  • I've completed a data repair cycle via the SMW admin panel
  • I've had my sysadmin run refreshLinks.php

None of these has corrected the problem. How do I make SMW rediscover these redirects? Thanks!

- Semantic MediaWiki 1.8 - MediaWiki 1.20.2 - PHP 5.3.19 (apache2handler) - MySQL 5.1.30

Michael Chidester

17:38, 26 February 2013

Posting this this the mailing list was the way to do it. :) Cheers

17:39, 26 February 2013