Help:Installation/Upgrade from SMW 1.8.x

Jump to: navigation, search
InstallationHelp:Installation/Upgrade from SMW 1.8.x
This pages describes the upgrade procedure for SMW 1.8.x.
Further Information
Installation type: upgrade
Installation method: N/A
Table of Contents


  1. Backup your database and installation.
  2. Delete the directories SemanticMediaWiki/ and Validator/ from the …/extensions/ directory.
  3. Remove the formerly required invocations of "Semantic MediaWiki" and "Validator" from the "LocalSettings.php" file, i.e. the following two lines:
    require_once "$IP/extensions/Validator/Validator.php";
    require_once "$IP/extensions/SemanticMediaWiki/SemanticMediaWiki.php";
  4. Re-install Semantic MediaWiki as described in the applicable page on installing SMW.
  5. Run the refresh database script from the base directory[1] of your MediaWiki installation:[2]
    php extensions/SemanticMediaWiki/maintenance/SMW_refreshData.php -d 50 -v
  6. Done!


  1. This is the directory which contains the "LocalSettings.php" file.
  2. This is an optional step to take to assure that the semantic store is valid and up to date.