Your requirements could not be resolved to an installable set of packages.

From semantic-mediawiki.org
< Installation‎ | Troubleshooting
Administrator manualInstallationInstallation/TroubleshootingYour requirements could not be resolved to an installable set of packages.

Issue[edit]

Composer issues "Your requirements could not be resolved to an installable set of packages." followed by "Installation failed, reverting ./composer.json to its original content."1

This issue appears for MediaWiki 1.29 and later when installing the respective point release from tarballs and issuing the following command:

composer require mediawiki/semantic-media-wiki "~2.5" --update-no-dev

Solution[edit]

The issue can be mitigated by running the following two commands:

composer update --no-dev
composer require mediawiki/semantic-media-wiki "~2.5" --update-no-dev
If you want to use a newer version of Semantic MediaWiki you have to specify the respective version, e.g. "~3.2" for the latest release series.