Semantic MediaWiki 1.5.3

Jump to: navigation, search
Semantic MediaWiki 1.5.3
Release date: 4 Nov 2010
Previous version: SMW 1.5.2
Next version: SMW 1.5.4
Compatible with: MW 1.14.x - 1.17.x
Current version
SMW 2.4.1

Version 1.5.3 of Semantic MediaWiki is the next minor release after SMW 1.5.2 that adds some new comparators and includes a number of internal fixes and software architecture improvements that improve SMW's extendibility.

Upgrading existing installations

Installations of SMW 1.5.x can be upgraded by just replacing the files (but note that you need to run MediaWiki 1.15 or greater now; this is strongly recommended anyway). This release is backward compatible with 1.5.2, so all extensions working with 1.5.2 should also work fine with 1.5.3. If problems do occur, it is possible to go back to 1.5.x by simply using the old files, and waiting with the upgrade until the relevant extensions provide updates.

It is suggested to change the inclusion of SMW in LocalSettings.php to the following as described in the installation instructions above:


Including SMW_Settings.php as in 1.5.0 and before will continue to work, but may be disabled in some future version.

For upgrading older versions, please see the installation instructions.


New comparators

This Semantic MediaWiki release introduces 4 new explicitly strict comparators, and a setting that allows changing the strictness of > and <. The new comparators are:

  • >> and <<: "greater than" and "less than"
  • and : "greater than or equal" and "less than or equal"

You can now change the default behaviour of > and < to be strict, meaning that values equal to what you are comparing to do not match the condition, by setting the new $smwStrictComparators setting to true. Note that this can affect behaviour of existing queries. When the value of the setting is not changed, there are no changes in the behaviour of these comparators, and full backwards compatibility is retained.

More information about their behaviour can be found on the strict comparators help page and the main comparator documentation.

Compatibility with MediaWiki 1.17

The upcoming MediaWiki 1.17 introduces a new JavaScript/CSS delivery system to speed up load and render time of pages, have automatic right-to-left support, and several other benefits. This does break existing JavaScript in many extensions, including SMW 1.5.2 and earlier. SMW 1.5.3 takes advantage of the Resource Loader when it's available, and falls back on the old code when it's not.

Code improvements and structure changes

Code style and structure has been improved to follow the general MediaWiki conventions and additional code documentation has been added at various places.

Extended translations

As usual, translations have been extended thanks to the project.


SMW 1.5.3 closes a number of bugs, including security related ones, and minor issues that have been identified in earlier versions.

This page in other languages: de

Semantic MediaWiki 1.5.3 en