sep seems not to work for tree format


Hi everyone,

using the tree format with SRF 1.7.1, I get results like this:

So the properties printed in the brackets are not separated at all. I tried to use the parameter


but it did not prove to have any effect.

Is this a bug or a case of misconfiguration? Any help appreciated!

PS I can see a bunch of fantastic new formats having come with SRF 1.8, really looking forward to using them. Thanks to all contributors!

12:46, 19 December 2012

So far I have not used this result format though I am looking forward to. Hmm, just by looking at the documentation it should work to get a separator in there somehow. Did you just try |sep=, to see what happens?

03:15, 20 December 2012

Hi kgh,

sorry for the late reply. Of course I tried, as mentioned above.

Kind regards

18:02, 1 February 2013

Heiya Argi, cool that this worked out for you. :) Cheers

23:00, 1 February 2013

Hi Argi, I reworked the treeview format lately. I did not specifically target this bug, but it could well have been solved in the process. Could you try if it works in the latest development version of SRF and if not raise a bug in [1]?

22:25, 13 May 2013

Hi F.trott,

due to a change in employment I do not have access to the installation anymore and thus cannot validate a fix. Next time I set up a wiki using it, I will take a look. Still, I cannot say when this is about to be. ;ö)

Thanks and regards


22:56, 11 June 2013

Everything qorking fine with MW 1.21 and SMW :)



12:49, 27 August 2013