Illegal property values + sorting

From semantic-mediawiki.org

> still not sure what the correct date is, effectively read as "just January 1990". Is there any workaround to use it in

I'm not sure what the problem is but annotations like Jan 1990 are supported, please have a look at [0].

Of course 1990-01-xx is not supported because the parser doesn't know how -xx should be interpret and I'm not entirely sure to have the parser in future to assume that it means Jan 1990.

[0] http://sandbox.semantic-mediawiki.org/wiki/Partial_dates

20:12, 27 April 2016

Oops, that's news to me. Did not know that this was working though admittedly a couple of years passed since I had a more intense peep at something like this. Great!

20:24, 27 April 2016
 

> I'm not sure what the problem is

Me and my inattention... Reading the official documentation always helps, and I'm very sorry for being not careful reading it. Thank you very much! Also I noticed that for some reason I used Has type::Text instead of Has type::Date for one my properties whilst the rest were and are well-typed. Fixed it locally.

P.S. It looks like YYYY-MM can work as well thus I need neither xx nor 00. That's awesome!

09:55, 28 April 2016