Selecting pages with non alphanumeric values for their Label


> currently having this problem: on our SMW all pages created with a form automatically get a Semantic Property "Label" that has the same value as the page name, so that we can search for it with #ask by querying on XYZ > alphanumeric characters such as ' " & the #ask fails (even in the Special:Ask page). I tried escaping or double-escaping

When reporting an issue you should always state the version (MW, SMW, SF etc.) you referring to. Aside from the unclear version, I'm a little bit unsure about the problem itself and the description is bit too ambiguous to pinpoint to a possible cause. I'd suggest you try to recreate your problem on [1] so that interested parties or developers can clearly understand the circumstances of your problem and have a reference to what your are referring to as `... contains non alphanumeric characters such as ' " & the #ask fails ...`.


04:35, 9 October 2016

Hey James, sorry for the confusion, what I mean is something along these lines:

I have a page with a Semantic Property that has a value that contains characters such as single quotes, double quotes or "&", such as the property Has text of this page

If I now run the queries that I setup in this page on my wiki, the only one that works is the second. The first and the third one show no results.

My wiki runs on MW 1.25.1 SMW 2.2.2 Semantic Forms 3.4 I tried to update SMW to 2.4.x on a local VM and the issue persists. The language of the wiki is set to Italian, if it can matter at all

Thanks for your patience

10:47, 10 October 2016